NForce4 PCI-E и S3 Trio64V+

Привет всем!

Есть следующий трабл:
Купил я намедни мать на NForce4 SLI - DFI LANPARTY UT nF4 SLI-D
Все дрова и BIOS последние...
Вышло так, что на видеокарту денег не хватило, придется месяц ждать з/п....
Есть проблема, описываемая/упоминаемая в этих топиках:
forums.overclockers.ru/viewtopic.php?t=36781


forums.overclockers.ru/viewtopic.php?p=1270834&highlight=trio64v#1270834
forums.overclockers.ru/viewtopic.php?p=622166&highlight=trio#622166
Короче, говоря - старушка S3 Trio64V+ заводиться на этой матери отказалась - Windows XP грит, мол, ресурсов не хватает. Каких - не конкретизирует, но в свойствах девуйсов NForce4 PCI Bus Management недоступны некоторые диапазоны портов (перечеркнуты красным), и в девайсе Ресурсы материнской платы - примерно тоже. Между слотами переставлял - их там всего 2 - фиолетово.
Рецептов решения нигде не увидел, но 16 цветов в WinXP - это жуть..:(

Есть какие-нить соображения?[/url]

Если данная информация оказалась полезной/интересной - плюсаните, пожалуйста:

Аватар пользователя savely

У S3 Trio кривая реализация PnP. Видимо Нфорсовый PCI-контроллер не может ее нормально сконфигурить. Балуйся настройками типа PIC/APIC, IRQ для VGA, PnP OS Yes/No - может, и поможет...

А кому счас легко...

PIC/APIC - мне винду тогды придется переставлять... :(
А она у меня уже 4 переезда живет.
(Заранее предупреждаю - руки прямые, так что насчет убитости винды - мимо тазика, даже на установленной в другой раздел с нуля - тоже самое).:)


Впрочем, попробую.
IRQ для VGA - в BIOS вообще нет такой настройки. (Насколько я знаю, S3 оно нужно обязательно, и мой BIOS в выдаваемом перед загрузкой ОС списке девайсов IRQ ей выделяет - так что это, скорее всего, не причина). Можно, в принципе, найти ModBin6, который сможет распаковать 4 MBit BIOS... но я не нашел, где. Мои 1.00.20 и 1.00.38 и 2.00.00 beta даже загрузить его не могут.
PnP OS... не подумал... по-моему, WinXP глубоко на это наплевать.
Попробую сегодня еще при отключенном APIC поставить винду рядом. И еще попробую PnP OS подергать.
Завтра напишу о результатах.
P.S. Сколько чипсетов и матерей с времени первого появления Trio64 сменилось - и все работало. А тут - на тебе - PnP глючный... shock

Аватар пользователя savely

Ну, могу объяснить тем, что у Интелов, VIA, SIS контроллеры PCI росли из младших. И если младшие работали - то и старшие тоже.
А NFORCE - абсолютно с 0. И на совместимость с S3 TRIO не тестил никто. wink

А с настройками BIOS - это типа "ну надо же что-то делать". Скорее всего, все же не поможет. Найди карточку другого производителя - Matrox, NVidia, Trident, Cirrus Logic.

Вообще, если есть знания - можешь глянуть, что там получается в PCI-регистрах у нее каким-нибудь сканером PCI (PCI.EXE, PCILIST.EXE).

А кому счас легко...

ПАнАдЕлают... #-o
Главное, блин в поддержке у DFI вообще молчат. У них-то толком и support'а по мылу нет.:( Пришлось на писать... и уже два дня - молчок... Еще попробую пнуть NVidia, вряд ли они, конечно, повернутся, но чем чёрт не шутит...

В общем, результаты эксперимента:
ФИОЛЕТОВО.
PnP OS, кстати, настройки вообще нет. Можно только ACPI и APIC вкл/выкл.
Общаюсь с суппортом DFI, пока парят, что сами попробовали - у них всё ОК.


Видать, моя Diamond Stealth 64 2001 имеет странный BIOS, хотя на сайтах, посвященных старому железу, BIOS от нее рекомендовали как наименее глючный.
Попробую сегодня зашить бета-БИОС для матери. Надо же что-то делать..:)

По ходу:
Во всяких PCI-диагностиках видать, что видеокарта дерется за область памяти F4000000-F7FFFFFF с девайсом 005C (PCI bridge). И, по-моему, еще неявно за некоторые порты (в нижней области памяти). Хотя в WinXP такого уже не наблюдается. То ли переконфигурирует она их, то ли просто тупит и не показывает конфликтующие ресурсы.
Действительно, кстати, видеокарта отсутствует в списке PnP устройств, формируемом BIOS 8-().
И еще эта неотключаемая опция ACPI SRAT в BIOS...
Еще я нашел, где в видяхе (PCI config cpace) хранится адрес занимаемой памяти, но при прописывании его на свободный участок (WPCRSET) - он сбрасывается на дефолтный, видимо, при загрузке видео-драйвера WinXP.
Попробовать бы другую версию видео-БИОС, да где её взять? Да и программатора у меня нет...
Короче, еще больше вопросов...

Аватар пользователя savely

Порты (типа 3B0h) и память (A0000h) в нижней - это железно (эмуляция стандартного VGA). И ей их дают - ибо как стандартный VGA она и работает. А верхнюю память - конфликт, вот дрова ее стартануть нормально и не могут... А вот почему контроллер PCI их с бриджем договорить не может - видать, из-за кривого PnP как раз...

Я бы плюнул и нашел другую.

А кому счас легко...

Аватар пользователя rgt

Maximin О том, что S3 работавшие на платах под сокет 7 могут глючить на более современных мне довелось убедиться лично. Более того об этом не раз писалось, в т.ч. и в этой конференции. Не пытайтесь это понять, просто запомните - эти видюхи могут не работать с платами, которые новее их, а если у кого-то они случайно работают, то это ничего не доказывает...

За несоответствие действительности Вашим о ней представлениям администрация форума ответственности не несет.

Rot: savely_s: Я бы плюнул, но из-за необходимости месяц пересидеть я не буду искать новую карту - нафик надо. А насчет не раз писалось - поиск по "Trio" не находит ни одного подходящего постинга.
Чтож делать... Впрочем, у меня есть еще пара запасных ходов.
Интересно же найти причину, а не "принимать, как есть" и "не пытаться понять".

Аватар пользователя rgt

Maximin

Цитата:
У S3 Trio кривая реализация PnP.

Это не достаточная причина ?
По поводу искать новую видюшку - никто этого и не предлогал. От себя мог бы предложить во временное пользование какую-то ATI 264 (тогда ATI делала видеокарты на своих процессорах только самостоятельно, изредка в виде исключения позволяя это АСУСу). Но у меня дома ремонт, и боюсь, раньше чем в конце следующей недели я до нее не докопаюсь...

За несоответствие действительности Вашим о ней представлениям администрация форума ответственности не несет.

Аватар пользователя Compiller

Могу выслать ModBin 2.01.01 (Мне его Borg No One выслал)
моему Albatron KX18DS PRO помогло (AwardPhoenix) другие ModBin не брали - мыло если что в личке аська там же

А вообще - когда-то на каком то форуме встречал способ лечения данного глюка в 2000 - на закладке видеодрайвера -> кнопка Дополнительно -> закладка Диагностика -> аппаратное ускорение - надо движок подвигать - лечилось - (правда это было в далёком 2001 году)

Кстати если тема актуальна - "новый" биос можно взять на фтп асуса
или поискать на поисковиках раньше в нете валялись исправленные версии и прошивалки от Diamond и Asus

Дрессируем коров :)

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img>
  • You can use BBCode tags in the text. URLs will automatically be converted to links.

Подробнее о форматировании текста

Антибот - введите цифру.
Ленты новостей