Модем Zyxel U-336E+, при включении пищит в линию

Модем при включении сразу же подымает трубку и начинает посылать туда сигнал с частотой где-то 3-5 кГц, при этом на АТ команды не реагирует. Принудительно ввёл его в кернел, перешил, но никаких изменений. Тут собственно идеи у меня и закончились. Первый раз такое вижу, да и с этой моделью общение происходило эпизодично. У кого какие идеи будут?

Если данная информация оказалась полезной/интересной - плюсаните, пожалуйста:

Трудно сказать что-нибудь умное по этому поводу. Единственно, можно рассуждать "от печки". Что чаще всего слетает в модемах, тем паче - в таких "фирмовых", как Зюхель ? Коммутатор номеронабирателя. При получении в линию такого, от чего другой просто окочурится. Причем, скорее всего, это был скачок по "земле" - между той, что с его родного БП идет и "землей" телефонной. Значит, где-то коммутирующий ключ, отвечающий за подъем трубы, пробит - шарим вокруг реле подъема трубы и реле номеронабирателя. По-моему, у них еще все на релюшках было... ну, заодно сами релюшки на предмет залипания проверить не мешает.

У вас прекрасные дети ! Но все, что вы делаете РУКАМИ - никуда, никуда не годится !

Ну тогда продолжаем рассуждать.
1) модем не отвечает на АТ команды, т.е. проблема в цифровой части


2) В кернеле, аналоговая часть работает нормально, трубка не поднята, никакого сигнала нету, перешивается модем нормально - т.е. COM интерфейс и частично проц, флеха работают.
3)В момент пищания в линии, модем мигает лампочкой HS, на сколько я понял, он пытается с кем-то соеденится (спрашивается зачем это ему нужно)

Из всего вышесказаного, можно сделать вывод, что проц просто ЗДУРЕЛ.
Есть идейка передуть проц с Zyxel Omni, потому как в маркеровке отличий не нашёл. Моджет кто-то делал подобное, катит такая замена или нет?

Den_of_Evill писал(-а):
1) модем не отвечает на АТ команды, т.е. проблема в цифровой части...

Наверное, Ты прав: процессор сразу после включения считает, что номер уже набран, судорожно подхватывает трубу... и начинает шейкать хендами. Вывод: Без даташита на сам проц - глухо. Сдувать я бы его не спешил, но вот кто в обвязке виноват... только даташит может сказать. А что, недоступны ?

А не отвечает на АТ-команды он именно потому, что занят своим внутренним делом: шейкает хендами. В этом режиме он на них реагировать и не должен.

У вас прекрасные дети ! Но все, что вы делаете РУКАМИ - никуда, никуда не годится !

Аватар пользователя savely

А если ему "брек" сказать? Как там - три плюса вроде... В общем - есть же команда, по которой "вывалится в режим прием AT-команд".

А кому счас легко...

ага, три плюса -"Escape code sequence. Entered while the modem is in Data Mode. Returns modem to Command Mode."
По лампочке TXD видно, что три плюса принимает, но никак на команду не реагирует.
Заметил ещё одно, когда можем пищит, через секунд 30 он ложит трубку, потом опять сразу же подымает, и опять начинает пищать. Тоже самое происходит и если нажать на кнопочку D/V - "Switches the modem into data mode or voice mode"
Нечистая сила сидит в модеме, надо бы танцами и бубнами злого духа изганять :D

Добавлено спустя 2 часа 16 минут 35 секунд:

УПС... дошаманил.
Может у кого завалялась полная прошивка с бутблоком на этот модем? :D

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img>
  • You can use BBCode tags in the text. URLs will automatically be converted to links.

Подробнее о форматировании текста

Антибот - введите цифру.
Ленты новостей