Maxtor D740X (6L080J4) & Promise FastTrak 100

Долго гадал, где разместить тему, решил все-таки здесь - объясняю, почему:
Подвалила работенка - заказной апгрэйд компа на базе материнки MSI K7T266 Pro2-RU, в состав необходимых доработок входит и создание РАЙД-массива 0+1...
На матери интегрированный Promise FastTrak100 Lite (чип с буковкой "R") - подумаешь, бином Ньютона (с) wink - естественно, был незамедлительно превращен в "полноразмерный" FT100 заменой модуля РАЙД в Бивисе матери (рутинная, практически до автоматизма отработанная операция - для данного варианта чипа даже ничего допаивать не надо, достаточно только замены БИОС и переустановки дров), а вот дальше вдруг начались грабли: РАЙД БИОС совершенно нормально, как и во всех случаях до этого, инициализируется, а потом начинает неожиданно долго искать подсоединенные к контроллеру устройства (стоит, как и до переделки, 80GB Maxtor D740X), затем происходит следующее (по частоте):

1. Просто тупо стоит, не реагируя на , - и --, только на ...
2. Говорит, что устройств нет, однако при входе в RAID BIOS Setup присоединенный диск обнаруживает, далее если не входить в сетап, то нормально продолжает грузиться, показывает в ОС, что все в порядке (есть и контроллер, и диск), если же войти в сетап, то после выхода из оного перезагружается и... читай сначала...
3. Выдает одну-две полные строчки точек (которые рисует во время свое инициализации и поиска устройств), а затем заявляет, что есть проблемы с распределением прерываний, ввиду чего он работать не желает и не будет (такое было лишь однажды - здесь грешу на опцию в БИОСе матери PnP OS Installed, но до вторника проверить не смогу)...
При выключенном в Бивисе матери РАЙДе проблем с загрузкой никаких; при физически отсоединенном диске тоже все в порядке - устройств просто нет, продолжаем грузиться далее...
Самое интересное, что этот диск отродясь без малейших проблем стоял на том же канале контроллера до момента переделки Lite в полный РАЙД, я даже шлейф не перетыкал (но на всякий случай поджал wink ), и нормальным образом виделся; однако, повторюсь, это у меня уже не первая такая переделка, да и, пожалуй, что и не десятая - раньше ничего даже отдаленно подобного не возникало...
Может, стоит принудительно понизить диску Максторовской утилитой предельный режим UDMA с 6 на 5 (контроллер-то максимально поддерживает ATA-100)?..
Или, возможно это мимо меня прошло, есть какие-то особые проблемы в совместимости Максторов с Промайсами - тогда мне прямо сейчас проще сказать хозяйке компа, что надо под ее заказ и диски менять...
Последнее: с питанием все в порядке, родной ИнВиновский корпус с ИнВиновским же 300Вт БП, под существующей нагрузкой практически не проседает...
У кого какие мысли, други?.. roll

Если данная информация оказалась полезной/интересной - плюсаните, пожалуйста:

Аватар пользователя rgt

Я бы в этой ситуации тупо менял бы следующее
1. Шлейф
2. Биос контроллера на "родной"
3. Диск
Причем именно в таком порядке, ибо IMHO так проще всего

За несоответствие действительности Вашим о ней представлениям администрация форума ответственности не несет.

Аватар пользователя ivp

Дело, как водится, было не в боббине... wink
И не в 1-2-3, а совсем даже в четвертом...
Традиционными методами околонаучного тыка и зашивания всего подряд во все что ни попадя wink , пока кто-нибудь не сдастся, выяснилось следующее: дело было в прошивке для RAID v.2.00.0.24 (BTW, как я понял, и в моей истории с ASUS CUBX тоже) - той, которая необходима для дров 2.00.0.25 с поддержкой LBA48 - не то в ней (хакнутой) парни с CrazyApe что-то напутали, не то она не любит переделанные Ultra@FastTrak, пока неясно, но стоило ее заменить на предыдущую версию (1.31 build 22), как тут же все заработало самым распрекрасным образом...


Пришлось, правда, сменить дрова на переделанные 2.00 build 18 (версия от тех же CrazyApe), про супер-большие диски забыть, да и фиг бы чей с ними - главное (пока wink ) работает...
Теперь "внимание, вопрос" :idea: ! ? - интересно, cможет ли кто-нибудь найти ответ, что и где сделано криво, вот ссылки:
1. Исходник 2.00.0.24
2. Хакнутый 2.00.0.24
3. Исходник 1.31.b.22
4. Хакнутый 1.31.b.22
Вот такая вот петрушка... roll

- Ситчик веселенький есть?..
- Приезжайте, обхохочетесь!..

Аватар пользователя Root

Жалко у меня Промиса для извратов нет:(:( А то бы подсоединился.

Аццкий ромбовод {:€
Я пока не волшебник - я только учусь! :-P

Аватар пользователя ivp

Впрочем, до конца еще не победил - дает создать Span на 2-х дисках поодиночке и парный, Stripe тоже, но как только пытаюсь зазеркалить существующий бутявый диск, так копирует до 1%, а дальше отказывается, с воплями о том, что массив не может быть создан, т.к. на одном из дисков имеет место быть ошибка...
Думал, что это из-за установленного атрибута сжатия (по аналогии - было дело, PartitionMagic мне гробил сжатые разделы при попытке смены размера кластера, чуть диск не запорол тогда, пока не понял, в чем дело), разжал, эффект тот же...


Видимо, или действительно есть проблемы с каким-то из дисков, или надо было изначально устанавливать систему на Mirrored Array - однако, досталось все в готовом виде, да еще и с 12GB документов, а свободного харда для бэкапа под рукой нетути...
Будем разбираться...

PS: Забыл добавить - при создании зеркала без копирования исходного диска никаких граблей...

- Ситчик веселенький есть?..
- Приезжайте, обхохочетесь!..

Аватар пользователя ivp

Неожиданное подтверждение выдвинутой выше теории - все-таки виноват БИОС с поддержкой LBA48 (и парни из CrazyApe совершенно ни при чем), подробности здесь...

- Ситчик веселенький есть?..
- Приезжайте, обхохочетесь!..

Аватар пользователя ivp

Разгромил собственную теорию о "виноватости" БИОСа с поддержкой LBA48 наголову - нормально он работает и с обычными дисками, просто CS не любит, ему строго MA или SL джамперами подавай...
Однако CUBX-E так и не сдалась, загрузку Бивиса переделанного Промайса не инициализирует, хотя под Виндой диски видны, работают, управляются Гуем, и т.п. roll

- Ситчик веселенький есть?..
- Приезжайте, обхохочетесь!..

Аватар пользователя ivp

Однако, погорячился я, похоже...
MSI 694D Pro2 (AWARD 6.0) действительно завелась с Промайсовским БИОСом v.2.0.00.24, а вот того же производителя KT266 Pro2-RU (AMI BIOS) при зашивке оного грузится (без хардов на Промайсе), а вот стоит их только повесить - как и раньше, тупо стоит после Scanning IDE...
Чудны дела твои, Господи... roll

- Ситчик веселенький есть?..
- Приезжайте, обхохочетесь!..

У меня была похожя ситуация
как я ее решил:
Перешил Биос мамки на родной а потом сделал апгрейд и все винт 80ВД стал нормально определяться в биосе. Обновление для биоса мамки я думаю можно найти на этом сайте

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img>
  • You can use BBCode tags in the text. URLs will automatically be converted to links.

Подробнее о форматировании текста

Антибот - введите цифру.
Ленты новостей