к звуковушке нужен биос E-MU® 0404 PCI (EM8852)

Всем доброе утро:)
Может быть кто то может поделиться биосом с рабочей карты.
можно на почту SinSe(собака)bk.ru

Если данная информация оказалась полезной/интересной - плюсаните, пожалуйста:

Аватар пользователя Baza

Вопрос: а как оно умерло? и как оно не работает?
и прошивок там по-моему несколько.

Либо нечему гореть, либо нечем поджечь!

Baza спасибо за интерес к моей теме:)(если с ней разбирусь отпишу как все было и выложу все что надо,будет неплохая ссылка:)
На нее драйвера перестали ставиться родные,хотя раньше все ставилось,но это со слов клиента.


Я еще не попробовал(это конечно не хорошо),но я на всякий случай биос попросил.Чтоб было как говориться:)
А звуковушка такая вроде одна,правда есть точно такая же но она с USB интерфейсом.Я почитал про их ремонт люди жаловались на подобные вещи.Но они выхадили из этой ситуации путем правки гдето в папке с дровами есть файлик,в корне программы.
Но мне хотелось всетаки навсякий случай биос образ с анологичной.

Аватар пользователя Baza

Понял, Vendor ID и Device ID обычно зашиты в SPI 93C46, 93C66 итп.
Pony Prog работает с ними на ура и другого софта до дури.

Сначала втыкаем её в комп и смотрим аидой или эверестом текущие VID и DID,
затем сравниваем со значениями из inf файла, или ищем в базе данных в инете именно для E-MU 0404 PCI.

А лучше и так и так:)

затем сдуваем епром, подключаем к программатору, сохраняем старый дамп обязательно!, и смотрим что там есть....как правило VID и DID там в явном виде, но может быть ещё CRC.

Либо нечему гореть, либо нечем поджечь!

Так продолжаем поиск выхода из сложившейся ситуации:)
Сегодня наконец то я вышел на работу,после болезни.И смог наконец то помучать эту звуковушку.
Ситуация состоит в следуещем.
1 При установке драйверов с диска она выводит что оборудование небыло найдено.
2 При установке дров насильно она ставит драйвер !Creative Audigi Audio Processor(WDM)(со знаком восклицания)
3 Я посмотрел в свойствах этой фигни была строчка PCI\VEN_1102&DEV_0008&SUBSYS_10001102&REV_00
4 Взял програмку wpcredit.exe и с помощью ее посмотрел
Vendor ID 1102
Device ID 0008
Subsystem Vendor ID 1102


Subsystem ID 1000
вот такое она показала.
5 Нашел файлик wdma_emu.inf в дистрибутиве с родного диска.Там строка
[Creative]
; EMU10K1 chip (SBLive!, APS)
%EMU10K1.DeviceDesc%=EMU10K1_Device,PCI\VEN_1102&DEV_0002&CC_040100 - похоже по настоящему должно быть.
6 Как мне показалось надо
Device ID 0008 заменить на 0002
Subsystem ID 1000 заменить на не уверен но это должно быть из числа 040100 ???? или как
7 Микросхема у меня CSI 24FC32JI.
8 Биос считал он ниже назван OLD.BIN(очень подозрительно маленький:()
9 Прогроматор у меня Тритон V5.7T(один из последних,клевая вещица)
BAZA расчитываю очень на вас ,как быть дальше:)
В поиске правильных бит в биосе я не селен и с этим у меня туго:((хотя программы на дельфи,паскаль писал на ура и всегда помогал всей группе)
Очень много почитал на iXBT про звуковушки эти,но правильный вендор и биос я для своей так нигде и не нашол.У всех либо карта не такая ,либо схожая ситуация.ЕЕ так и не решили если я не ошибаюсь.
Инет на работе ООчень плохой не успел до конца прочесть там порядка 300 страниц.
Люди отзовитесь кто нито с такой звуковушкой,рано или поздно у вас может случиться такая же ситуация.У них это повально:(

ВложениеРазмер
OLD.bin 4 КБ
Аватар пользователя Baza

Странно, судя по даташиту на 24FC32 там должно быть 32кб.
Попробуй сделать дамп Pony-Prog -ом.

forum.ixbt.com/topic.cgi?id=90:12-7
ключевая фраза: как и без чипа епром.

Либо нечему гореть, либо нечем поджечь!

Аватар пользователя Baza

article.gmane.org/gmane.linux.alsa.user/29143


Цитата:

HiI've just built latest snapshot alsa drivers, I have an emu0404 pci
card. The card failed to get properly detected, lspci revealed it had a
device ID of 0x0008 not 0x0004 so I changed:

> {.vendor = 0x1102, .device = 0x0004, .subsystem = 0x40021102,
> .driver = "Audigy2", .name = "E-mu 0404 [4002]",
> .id = "EMU0404",
> .emu10k2_chip = 1,
> .ca0102_chip = 1,
> .spk71 = 1,
> .emu_model = EMU_MODEL_EMU0404}, /* EMU 0404 */

to

> {.vendor = 0x1102, .device = 0x0008, .subsystem = 0x40021102,
> .driver = "Audigy2", .name = "E-mu 0404 [4002]",
> .id = "EMU0404",
> .emu10k2_chip = 1,
> .ca0102_chip = 1,
> .spk71 = 1,
> .emu_model = EMU_MODEL_EMU0404}, /* EMU 0404 */

Либо нечему гореть, либо нечем поджечь!

Baza приветствую:)
Pony-Prog -ом у меня нету.Но с моим Тритоном у меня никогда проблем небыло,читал и шил все.
Выяснилась, оказывается она уже у кого то была в ремонте и с биосом уже что то делали.Но концов боюсь не найти:(
Я попробовал повобирать из списка похожие микросхемы в моем прогроматоре,но дамп хоть тресни только такой и с одной и тойже суммой.
ниже картинка микросхем из списка.
Похоже надо биос и подругому никак:(

ВложениеРазмер
Mikroshemy_spisok.GIF 81.44 КБ
Аватар пользователя R_Soft

Baza писал(-а):
Странно, судя по даташиту на 24FC32 там должно быть 32кб.

Baza, ничего странного. В маркировке указываются килобиты. 32 кб (килобита) = 4 кБ (килобайта). Приведенная прошивка длиной 4 кБ.
Следует учесть, что кроме указанных в прошивке Vendor ID & Device ID, на плате могут быть (не утверждаю что так и есть, именно есть такая возможность) бутстраповые (boot strap) резисторы конфигурации Device ID, наподобе как у видеокарт. Хотя, это слишком маловероятно. Действительно, похоже на слет конфигурационной флеши.
Между прочим, с полмесяца назад мучался подобным образом с картой SB Live! 5.1 Digital Model:SB0220, чип Creative EMU10K1-JFF. Конф. флешь U12 - CSI 93C46S. Ни один из найденных драйверов не стал (а нашел их с десяток).

Партизан подпольной луны aka (R)soft

Аватар пользователя Baza

32кб....да, ступил....бывает:)

надо глянуть как у аудиги и у лайфа оно кодируется в прошивке, на том-же
sblive.narod.ru...и сваять свою прошивку.

Либо нечему гореть, либо нечем поджечь!

Аватар пользователя R_Soft

Сваять прошивку осознанно (или вдумчиво) без даташита на чип будет проблематично, скорее даже невозможно. Разве что по наитию...

subsystem = 0x40021102

по смещению 0x03, ИМХО, причем НЕ в "перевернутом" виде как привыкли аля Lo Hi
Что-то мне подсказывает, что vendor = 0x1102 & device = 0x0008 в явном виде в прошивке нет, скорее всего "зашито" аппаратно.
Получается Subsystem Vendor ID 1102 по смещению 3, а вот с Subsystem ID 1000 не понятно откуда оно берёт. Наверно это дефолтные значения если внешней конф. флеши нет или она читается с ошибкой (как вариант, после чтения проверяется КС, которая обычно расположена в двух последних байтах прошивки).

Партизан подпольной луны aka (R)soft

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img>
  • You can use BBCode tags in the text. URLs will automatically be converted to links.

Подробнее о форматировании текста

Антибот - введите цифру.
Ленты новостей