Sapphire HD7870 запускается через раз.

Привет. Помогите по диагностике. Заодно хочу понять эти импульсные системы. Sapphire HD7870 GHz Edition. Проблема именно в видеокарте, проверялась в разных системах, БП 450W и 650w. Другие видеокарты карты работают в них нормально, поэтому проблемы из-за других компонентов исключены.

Материнки с этой картой стартуют через раз. Питание подается, кулеры вращаются, на мат. плате горит верхний ряд светодиодов(который гаснет при загрузке). Посткарты нет, звуковых сигналов при незапуске нет. Ничего не менял, не паял, не грел, карту никто не ковырял. Если запустилась – работает относительно нормально, запускал пару игрушек - никаких вылетов пока не замечено, но сильно ее не рискнул нагружать.
Напряжения питания на карте при не запустившейся системе(ГПУ греется, СО работает):
[url=]s018.radikal.ru/i518/1511/5c/cff86501b966.jpg[/url]


Единственное что удалось обнаружить, большое сопротивление на дросселе L701(шина питания памяти?) 236 Ом. Нормально это или нет? Посмотрел осциллографом форму импульсов:
на дросселях ГПУ :
[url=]s018.radikal.ru/i512/1511/77/3f67d44a7a63.jpg[/url]
на L801 :
[url=]s020.radikal.ru/i701/1511/a9/3e28040551f6.jpg[/url]
а на L701 вот такая фигня:
[url=]s019.radikal.ru/i613/1511/80/2274a49b25bb.jpg[/url]
вернее это на ШИМе APW7165C. Частота там почти все время 300КГц, но иногда кратковременно появляется такая как на фото, 60МГц.
Даташит на шим:
[url=]anpec.com.tw/ashx_prod_file.ashx?prod_id=715&file_path=201312041819475...[/url]
Проверил обвязку, вроде все целое, обрывов и кз нет. Напряжения вроде все в норме:
[url=]s015.radikal.ru/i330/1511/bf/82dfe9075d4e.png[/url]
напряжение на выводе 4, если карта запускается, поднимается до 8.8v.
Проверил осциллом весь ШИМ, вот такие картинки на выводах 1,2,4,8:
[url=]s017.radikal.ru/i408/1511/78/906dbad78e7c.jpg[/url]
[url=]s018.radikal.ru/i517/1511/fc/0095b082b71f.jpg[/url]
[url=]s015.radikal.ru/i331/1511/27/3f991351eb64.jpg[/url]
[url=]i081.radikal.ru/1511/6f/bca9ef80d38f.jpg[/url]
Когда карта все-таки запускается, то форма импульсов на выводах 1,2,8 меняется на относительно нормальную, 8 вывод:
[url=]s005.radikal.ru/i212/1511/b7/fcb08c4f2d95.jpg[/url]
а на 4 выводе импульсы инвертируются:
s014.radikal.ru/i329/1511/ce/828c4af515b8.jpg

Проблема карты в этом или это только следствие? Если правильно понял, то проблема или в самом ШИМе, или в обвязке. В нагрузке(сама память) проблемы быть не может? При незапустившейся системе на 7 выводе ШИМа присутствует(оно там сразу есть) напряжение 1,2-1,3v. При наличии этого напряжения ШИМ должен запуститься, я правильно понимаю? Или есть еще какие-то разрешающие/запрещающие сигналы? Английский не знаю, поэтому полностью даташит осилить мне трудно.

Если данная информация оказалась полезной/интересной - плюсаните, пожалуйста:

Аватар пользователя Aleksey_56

На FB какое напряжение при запуске/незапуске? Резистор и конденсаторы на выводе COMP проверены? Было нечто подобное

Легче всего создаются трудности.

FB - 0.6v сразу присутствует, после старта системы остается такое же. В нерабочем режиме пока замерить не могу, теперь карта начала запускаться все время. На COMP вроде все целое, напряжение 1.3v. Как снова упадет в нерабочий режим - посмотрю осциллографом что в момент загрузки происходит на COMP и FB. Спасибо, та тема помогла лучше понять. Разница в том, что у меня-то на выходе преобразователя 1.5v есть все время, даже когда система не стартует.

Аватар пользователя Aleksey_56

Цитата:
у меня-то на выходе преобразователя 1.5v есть все время, даже когда система не стартует.
Так по картинкам в момент не запуска на COMP явные проблемы, тем более шим периодически сваливается в старт/стоп режим. maco конечно может больше "рассказать" или поправить меня, так что ждите от него подсказок.

Легче всего создаются трудности.

Наконец-то опять карта в нерабочий режим свалилась. На FB ничего не меняется, в любом режиме стабильно 0.6v. А на COMP посмотрел, когда система стартанула, то в момент старта напряжение поднимается до 1.4v. Если не стратует - остается 1.25-1.3v.

Цитата:
Так по картинкам в момент не запуска на COMP явные проблемы, тем более шим периодически сваливается в старт/стоп режим. maco конечно может больше "рассказать" или поправить меня, так что ждите от него подсказок.

На COMP какие там картинки неправильные, там ведь просто постоянка?

На картинках, если я правильно понимаю, не только в момент не запуска проблемы, при запуске тоже форма импульсов ШИМ неправильная(кроме вывода 4, на нем нормальные). По линии COMP: C1, C2, R3 - вроде все целое. Транзистор Q3 целый, дальше не смотрел.
Схема включения шим: s015.radikal.ru/i330/1511/bf/82dfe9075d4e.png
В даташите по выводу COMP указано 0.6V, выше которого он должен запускать ШИМ, правильно? Значит проблема не в этом. Попробую еще раз по даташиту все проверить.

проверте кварц, биос, может быть где то обрыв и контакт временно восстанавливается

Разбираюсь потихоньку, ШИМ запускается(и он запускается) по наличию достаточного напряжения на COMP при наличии VCC. FB - обратная связь, контролирующая Vout. По LGATE импульсы нормальные, значит генератор импульсов работает нормально. А если он работает нормально, то по COMP, FB, VCC все в порядке, иначе были бы другие проблемы на выходах. Неисправен выход UGATE ? Полевики проверил, звонятся нормально, и на выходе напряжение есть, так что отпадают. Не хочу тупо ШИМ менять. Обвязку всю 10 раз поверил, вроде все целое. Форма импульсов может искажаться, например, из-за утечек в керамике? Еще раз повторю, по Vout напряжение есть, 1,5 Вольта, если бы его не было, тогда было бы понятно, но оно есть всегда, даже когда карта не запустилась и импульсы кривые. Бред какой-то. Все равно ведь LC цепочка на выходе сглаживает кривые импульсы. COMP - это еще и обратная связь, контролирующая правильную работу ШИМа?
В даташите конечно все расписано, но переводчик выдает такой непотребный винегрет, что бросил это занятие.
А более подробных схем не бывает? Block Diagram в даташите - это ведь только общая схема.

И никто не подскажет, жрут попкорн, ржут и смотрят. :)

Цитата:
проверте кварц, биос, может быть где то обрыв и контакт временно восстанавливается

Кварц и биос тут причем? Проблема по питанию памяти уже вроде локализована, если я правильно понимаю. Если я не прав - напишите подробнее почему так считаете. Просто начать проверять все подряд не вижу смысла.

Аватар пользователя Bishop

а если предположить, что этот источник на самом деле исправный, а "порченная ослограмма" отражает тот факт, что источник работает почти вхолостую, т.е. потребитель не кушает расчётный ток?
...набил рот попкорном

...ложки нет

Если ШИМ работает, а потребитель выключен, почему должна измениться форма импульсов? А почему тогда на выходе 4 (LGATE) импульсы нормальной формы? Забыл проверить греется ли память, тогда будет понятно, жрет она или спит. Когда опять карту начнет плющить(сейчас работает), проверю температуру чипов.

Аватар пользователя Bishop

...я хотел слегка намекнуть на контроллер памяти

...ложки нет

Цитата:
а если предположить, что этот источник на самом деле исправный, а "порченная ослограмма" отражает тот факт, что источник работает почти вхолостую, т.е. потребитель не кушает расчётный ток?
...набил рот попкорном

Можно было не предположить, а пнуть меня в конкретный пункт даташита(я до него раньше не добрался, т.к. не знаю язык, тем более технический):
"Pulse Skipping Mode (PSM)
At light loads, the inductor current may reach zero or reverse on each pulse. The low-side MOSFET is turned off
by the current reversal comparator, IZCMP, to block the negative inductor current. In this condition, the converter
enters discontinuous current mode operation. At very light loads, the APW7165C will automatically skip
pulses in pulse skipping mode operation to reduce switching losses as well as maintain output regulation
for efficient applications."

Я не все тут понимаю, поправьте если не правильно. ШИМ находится в нормальном состоянии, а "кривые" импульсы - это просто режим работы с малыми нагрузками, и как раз на LGATE у меня импульсы инвертированы: The low-side MOSFET is turned off
by the current reversal comparator.

Цитата:
...я хотел слегка намекнуть на контроллер памяти

Если выше все правильно, то почему тогда именно память? Может дело вообще в другом? Надо тогда смотреть последовательность запуска всех напряжений и сигналов на карте. Где нибудь есть общее описание старта и работы видеокарт, что за чем запускается?

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img>
  • You can use BBCode tags in the text. URLs will automatically be converted to links.

Подробнее о форматировании текста

Антибот - введите цифру.
Ленты новостей