Помогите прошить BIOS Radeon ASUS 3870

Беда. В общем вшил я сдуру в 3870HD её же родной биос, но в Radeon Bios Editor выставил не 3870, а 5770. И вшил. Итог - карта грузится, всё показывает, в виндовсе драйвер не ставится, GPU-Z не показывает половину данных (в том числе модель видеокарты). Ну думаю хватит, наигрался, надо вернуть оригинальный биос назад. А не тут-то было. AtiWinFlash и AtiFlash - обе говорят "adapter not found" и не хотят шить.
Помогите, как вернуть ей рабочий БИОС? Карта-то рабочая, всё показывает и грузится и биос оригинальный имеется. А шиться не хочет. Жалко теперь выбрасывать карту.

Если данная информация оказалась полезной/интересной - плюсаните, пожалуйста:

Аватар пользователя BHyK

гугл так пишет

Цитата:
Для отката нужно найти старую PCI-видеокарту, либо поставить «больную» карту в материскую плату с интегрированым графическим адаптером, загрузиться с подготовленого нами носителя с прошивальщиком и файлами BIOS.
После загрузки и вывода приглашения DOS дать команду:
atiflash.exe -p -f 0 old.rom
old.rom - сохранённый биос от Вашей видеокарты/quote]

Идея не несет ответственности за тех, кто в неё верит

Та гугл то понятно. Но этого недостаточно в моём случае. Но я справился. Спасибо интернету великому.
У меня ж получился неверный идентификатор карты и прошивальщик его не понимает и не хочет писать. не зависимо от параметров командной строки для него. Ксчастью, как я сегодня узнал, на Радеонах есть идентификатор проца вшит в проц и он может быть подменен в биосе видеокарты. Соответственно, если в биосе неверный - единственный вариант отключить БИОС вообще чтобы программа считала идентификатор который выдаёт GPU.
1) Находим микросхему БИОС на плате видюхи
2) Ищем даташит. У меня это 25LV512.
В нем видим, что за выбор чипа отвечает нога 1. Если подтянута на +3,3V - то чип в спящем состоянии, если на землю - то чип активен.


3) Закорачиваем ногу 1 на ногу 8(3,3V). Стартуем ПК.
В биосе материнки видеокарта должна стоять включенная( у беня мать видео на борту, я выбрал вариант "сначала PCI-e, потом Integ.") К сожалению пункта инициализировать сначала интегрированную, а потом PCI-E у меня нету, дальше все действия выполнял вслепую. Т.к первой инициализируется PCI-E, а без БИОСа она не стартует и изображения нет.
Так вот, стартуем ПК, он ругается и пищит динамиком (даже не стал вдумываться, что именно пищит, т.к. дальше грузится и хорошо. Видать орет что PCI-E видюха не работает.
4)Дальше вслепую гружа загрузочную флешку.
5) Убираю соединение 1й и 8й ног.
6) Заветные команды - atiflash.exe -f -p 0 old.rom
7) Жду с минутку, пока точнозальётся БИОС и рестарт.
8) Вуаля, прошилось.

Отправить комментарий

Содержание этого поля является приватным и не предназначено к показу.
  • Разрешённые HTML-теги: <a> <em> <strong> <cite> <code> <ul> <ol> <li> <dl> <dt> <dd> <img>
  • You can use BBCode tags in the text. URLs will automatically be converted to links.

Подробнее о форматировании текста

Антибот - введите цифру.
Ленты новостей